Linux Distrolarında yaşadığım genel performans sorunu

Herkese iyi pazarlar. i7 4712mq ve gt 840m’li laptobumda hangi distroyu kullanırsam kullanayım yaşadığım ve neden kaynaklandığını bilmediğim bu bezdirici sorunlar beni deli etmek üzere. Her distro kasıyor. Tüm masaüstü ortamlarını denedim, birçok distroyu da denedim. Hepsinde aynı sorun var.

Dün gece bir de Linux Mint Cinnamon deneyeyim dedim ve kurdum. Live versiyonda her şey kusursuz ve inanılmaz akıcı işliyor. Bir süre kullandım, videoları da açması gerektiği gibi açıyor. Diske kurduğumda ise sorunlar başlıyor.

Önerilen özel mülkiyet NVIDIA driverlarını kurdum, gpu olarak intel değil nvidia kullanılıyor, orada bir sorun yok. Bunlara rağmen basit bir youtube videosunu bile akıcı oynatamıyorum. Şu yazıyı bile akıcı yazamıyorum. İşin daha kötü kısmı, Windows daha ağır olması gerekirken çok daha akıcı bir kullanımı var. Hiç mantıklı gelmiyor. Üstelik distroları live’da kullanırken bu kadar yumuşak ve yağ gibi çalışması fakat kurulumdan sonra bu kadar hantallaşmasının sebebini de anlayamadım.

Web’de bir çözüm de bulamadım uzun süredir bu sorunu yaşamama rağmen. Yardımlarınız için şimdiden teşekkürler.

1 Like

Bu bahsettiğiniz sorun genel olarak ekran kartı problemiymiş gibi gözüküyor. NVIDIA sürücülerini düzgün kurduğunuza ve sisteminizin donanım hızlandırmayı kullandığına emin misiniz?

Sisteminiz kasarken/yük altındayken acaba CPU değerleri neler?

htop / nvidia-smi ekran görüntüsünü paylaşabilir misiniz?

Aynı zamanda sudo iotop komutunu çalıştırarak diskinizde anormal yazma/okuma var mı bakmanız gerekli.

Sorunun nereden kaynaklı olduğunu bulmalıyız. Dediğim gibi tarif ettiğiniz sorun ekran kartı sürücü sorunu gibi geliyor ama oradan olmadığına eminseniz bahsettiğim yerlerden anormalliği bulmamız gerekecek.

1 Like

Cevap için teşekkürler, driverların düzgün olduğundan eminim hocam:

Screenshot from 2023-10-23 15-11-33

Aynı zamanda Firefox’ta donanım hızlandırma aktif.

1080p60fps bir youtube videosu oynarken htop değerleri şu şekilde:

nvidia-smi değerleri ise şöyle:

sudo iotop çıktım da şu şekilde:

HDD mi kullanıyorsunuz SSD mi?

1TB HDD ve 8gb ddr3 bellek.

Merhaba. nvidia-settings’e girip şu kısmı kontrol eder misiniz?


MUX’suz cihazlarda “Synchronization” kısmının On olması gereklidir. Bu özellik iGPU ve NVIDIA GPU arasına ek bufferlar yerleştirerek tearing sorununu ortadan kaldırır ancak input lag yaratır. Eğer “On” iken kasıyormuş hissi varsa Prime Synchronization’un yarattığı input-lag size fazla gelmiş olabilir. Bu herkeste aynı etkiyi yaratmayabilir ancak input lagın arttığı da bir gerçek. Bu durumda on-demand moduna alıp Intel iGPU’dan çıktı alarak input lagı azaltabilirsiniz, oyunlarınızı NVIDIA’dan oynamak isterseniz Prime Render Offload modu size fayda sağlayabilir. Bunun haricinde inxi -FxxG komutunun çıktısını atarsanız genel sistem özelliklerinize bakabiliriz.

hocam zaten sync on durumdaymış. yani oyun falan oynayamıyorum zaten, zira basit bir youtube videosunu bile 60 fps oynatamıyor linux nedense.

inxi -FxxG çıktım:

mastermind@mastermind:~$ inxi -FxxG
System:
  Host: mastermind Kernel: 5.15.0-87-generic x86_64 bits: 64 compiler: gcc
    v: 11.4.0 Desktop: Cinnamon 5.8.4 tk: GTK 3.24.33 wm: muffin dm: LightDM
    Distro: Linux Mint 21.2 Victoria base: Ubuntu 22.04 jammy
Machine:
  Type: Desktop System: CASPER BILGISAYAR SISTEMLERI A.S
    product: CASPER NIRVANA NOTEBOOK v: 1.0 serial: <superuser required>
    Chassis: type: 3 serial: <superuser required>
  Mobo: CASPER BILGISAYAR SISTEMLERI A.S model: C15B v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: C15B.617
    date: 01/08/2015
Battery:
  ID-1: BAT0 charge: 16.3 Wh (95.9%) condition: 17.0/48.4 Wh (35.1%)
    volts: 12.4 min: 10.8 model: PEGA B34Y-22 serial: N/A status: Not charging
CPU:
  Info: quad core model: Intel Core i7-4712MQ bits: 64 type: MT MCP
    arch: Haswell rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 6 MiB
  Speed (MHz): avg: 2268 high: 3257 min/max: 800/3300 cores: 1: 1158
    2: 2925 3: 1116 4: 860 5: 3002 6: 2859 7: 2970 8: 3257 bogomips: 36714
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Pegatron
    driver: i915 v: kernel ports: active: eDP-1 empty: HDMI-A-1,VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0416
  Device-2: NVIDIA GM108M [GeForce 840M] vendor: Pegatron driver: nvidia
    v: 535.113.01 pcie: speed: 2.5 GT/s lanes: 4 bus-ID: 01:00.0
    chip-ID: 10de:1341
  Device-3: Chicony USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-10:6 chip-ID: 04f2:b3a3
  Display: x11 server: X.Org v: 1.21.1.4 driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 102
  Monitor-1: eDP-1-1 mapped: eDP-1 model: LG res: 1366x768 dpi: 101
    diag: 396mm (15.6")
  OpenGL: renderer: NVIDIA GeForce 840M/PCIe/SSE2
    v: 4.6.0 NVIDIA 535.113.01 direct render: Yes
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Pegatron driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c
  Device-2: Intel 8 Series/C220 Series High Definition Audio
    vendor: Pegatron driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
    chip-ID: 8086:8c20
  Sound Server-1: ALSA v: k5.15.0-87-generic running: yes
  Sound Server-2: PulseAudio v: 15.99.1 running: yes
  Sound Server-3: PipeWire v: 0.3.48 running: yes
Network:
  Device-1: Realtek RTL8723AE PCIe Wireless Network Adapter vendor: AzureWave
    driver: rtl8723ae v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 03:00.0 chip-ID: 10ec:8723
  IF: wlp3s0 state: up mac: 40:e2:30:b5:57:68
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Pegatron driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: c000 bus-ID: 04:00.0 chip-ID: 10ec:8168
  IF: enp4s0 state: down mac: 00:71:c2:19:98:c9
Bluetooth:
  Device-1: IMC Networks Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-6:5 chip-ID: 13d3:3394
  Report: hciconfig ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: 40:E2:30:B5:AD:A9
Drives:
  Local Storage: total: 931.51 GiB used: 17.44 GiB (1.9%)
  ID-1: /dev/sda vendor: Western Digital model: WD10JPVX-22JC3T0
    size: 931.51 GiB speed: 6.0 Gb/s serial: WD-WX21A554S9RK
Partition:
  ID-1: / size: 292.26 GiB used: 17.39 GiB (6.0%) fs: ext4 dev: /dev/sda7
  ID-2: /boot/efi size: 96 MiB used: 47.4 MiB (49.4%) fs: vfat
    dev: /dev/sda1
Swap:
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
Sensors:
  System Temperatures: cpu: 80.0 C mobo: N/A gpu: nvidia temp: 69 C
  Fan Speeds (RPM): N/A
Info:
  Processes: 285 Uptime: 5h 59m Memory: 7.66 GiB used: 3.43 GiB (44.8%)
  Init: systemd v: 249 runlevel: 5 Compilers: gcc: 11.4.0 alt: 11/12
  Packages: 2265 apt: 2255 flatpak: 10 Shell: Bash v: 5.1.16
  running-in: gnome-terminal inxi: 3.3.13

Bilgisayarınızın ciddi derecede sıcak olduğunu fark ettim. Bu çıktıyı oyun falan oynadıktan sonra mı çektiniz?

Hayır hocam, Discord bile kapalı. Birkaç Firefox sekmesi açıktı yalnızca. Şu an sadece oynatılmayan bir youtube sekmesi bir de bu sayfa açık, işlemci 77 derece.

Bence sıcaklıktan throttling yapıyor. Bilgisayarınız adı sanı çok olmayan bir markaya ait ki fan için gerekli sürücü veya arayüz bulunmayabilir, bilgisayar fanını ayarlayamadığından sıcak kalıyor olabilir. Boşta bir bilgisayar için çok fazla. Windows’da performans sorunu olmadığını söylemiştiniz. Belki bilgisayara bakım yapmak kökten çözebilir. Şimdilik NVIDIA GPU’yu güç tasarrufu moduna alarak kullanmayı deneyin. Bakalım sorununuzu çözecek mi?

Evet hocam, bilgisayar kötü. Bakımı ben de düşündüm fakat donanımlardan ziyade sürücü/yazılım tarafında bir sorun var gibi geldi zira bahsettiğimiz gibi Windows’ta daha iyi bir performans alıyorum, ki orada da işlemcimin çok serin olduğu söylenemez… Bu olay da beni şaşırtıyor işte. Yani tamam artık Linux’ta bile böyleyse bilgisayarı artık çöpe atalım desem, Windows’ta daha iyi deneyim olmazdı zaman. Linux’u doğru dürüst çalıştırmayacak kadar da kötü bir donanımı yoktur sanıyorum bilgisayarın, nitekim Windows’ta bu tür sorunları yaşamazken Linux’ta yaşamam ilginç geliyor. Üstelik live versiyonlada hiçbir sorun yok. Ne fan sesi duyuyorum ne de hantallıkla ilgili bir sorun var. Son derece akıcı, smooth. Video oynatırken falan da herhangi bir sorunum olmuyor, yani bu mevzubahis problemlerin hiçbirisi yok. Kurulumdan sonra başlıyor olaylar… Bu neden kaynaklı olabilir?

Bu arada şu an NVIDIA on-demand modundayım ve daha da beter oldu.

On-demand modunda ne oldu? inxi -G yazınca ne çıkıyor?

Performance modunda da on-demand modunda da inxi -G çıktım aynı:

mastermind@mastermind:~$ inxi -G
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
    v: kernel
  Device-2: NVIDIA GM108M [GeForce 840M] driver: nvidia v: 535.113.01
  Device-3: Chicony USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 1.21.1.4 driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa gpu: i915
    resolution: 1366x768~60Hz
  OpenGL: renderer: NVIDIA GeForce 840M/PCIe/SSE2
    v: 4.6.0 NVIDIA 535.113.01

Aktif olması için çıkış yapmanız sonra tekrar giriş yapmanız lazım. Bunu da yaptıysanız ve Performans ile on-demand modunda da NVIDIA açılıyorsa güç tasarrufu moduna geçin. Güç tasarruf modunda OpenGL: renderer: kısmında Intel olması lazım. Bilgisayarı bu durumda kullanmayı deneyin. Ondan sonra olmadıysa başka bir şeyler düşünürüz.

Çıkıp girdim hocam aktif olması için. Şu an on-demand’dayım ve 1080p60fps video izlerken 91 derece gördü işlemci… Güç tasarrufu moduna geçiyorum şimdi.

Şu an power saving moddayım ve en kötü performansı bu verdi. Bu yazıyı yazarken dahi güçlük çekiyorum.

inxi -G çıktım:

mastermind@mastermind:~$ inxi -G
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
    v: kernel
  Device-2: NVIDIA GM108M [GeForce 840M] driver: nvidia v: 535.113.01
  Device-3: Chicony USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 1.21.1.4 driver: X:
    loaded: modesetting,nvidia unloaded: fbdev,nouveau,vesa gpu: i915
    resolution: 1366x768~60Hz
  OpenGL: renderer: llvmpipe (LLVM 15.0.7 256 bits)
    v: 4.5 Mesa 23.0.4-0ubuntu1~22.04.1

llvmpipe yani işlemciye yük bindirmiş. Güç tasarrufu modunda bilgisayarı yeniden başlatıp dener misin? Bu da olmazsa, gene llvmpipe çıkarsa, performansta gene sorun yaşarsan performans moduna al. Diğer olası sorunlara eğilelim sonrasında.

Hocam livmpipe çıkmadı fakat bir manası olmadı bunun. Performans epey kötü. Bir video açtım ve peak yaptığı yerlerde 90-95 derece gördü işlemci. Çıktım şu şekilde:

mastermind@mastermind:~$ inxi -G
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics driver: i915
    v: kernel
  Device-2: NVIDIA GM108M [GeForce 840M] driver: N/A
  Device-3: Chicony USB2.0 HD UVC WebCam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 1.21.1.4 driver: X: loaded: modesetting
    unloaded: fbdev,vesa gpu: i915 resolution: 1366x768~60Hz
  OpenGL: renderer: Mesa Intel HD Graphics 4600 (HSW GT2)
    v: 4.6 Mesa 23.0.4-0ubuntu1~22.04.1

Yeniden performans moduna alıyorum. Yavaş moda geçilmiş bu arada. Biraz beklemek durumunda kalıyorum yanıt verirken. Kusura bakmayın.

Her şeyi toparlayacak olursak ben işlemcinin aşırı ısınmasından kaynaklı olarak bilgisayarınızın yavaşladığını seziyorum. Bunu da iki olası sebebe bağlıyorum:

  • Bilgisayarınız yıllar içerisinde temizlenmediğinden fanları toz-pislik dolu ve termal macun kurumuş ki işini yapamıyor.
  • Bilgisayarınız markasız olduğu için doğru düzgün fanı yönetecek sürücüsü yok ki bilgisayar fanı hızlandırıp soğutamıyor.

Bunun haricinde donanım hızlandırma açmak bir fayda sağlamaz. NVIDIA GPU’nuz en güncel H264 çözebilir ki bunu sadece NVENC ve VDPAU ile yapabilir. Bu iki teknolojiyi hiçbir modern tarayıcı desteklemiyor. Bununla beraber H264 tarihe gömülmüş bir codec. YouTube sadece AV1(RTX 3000 veya RX 6000) ve VP9(GTX 1000 serisi ve sonrası) kullanıyor ki bunları çözebilmek için güncel ekran kartına ihtiyacınız var. Intel GPU’da da bundan çok farklı değil. Her halükarda işlemci kullanılacak.

Bunun haricinde Linux, diske karşı hassas olan bir işletim sistemi. Diskiniz bozuksa veya yavaşsa bilgisayarınız çok daha fazla olumsuz etkilenecektir bu duruma Windows’a kıyasla.

Bu sorunlarının hiçbirini kendiniz hemen çözemezsiniz. Bilgisayar temizlenir ve yenilenirse macunu garanti vermiyorum ancak bir şansımız olabilir. En azından bilgisayarın fanı çalışıyor mu? Yani ısındıkça fan sesinin arttığını duyabiliyor musunuz? Duyamıyorsanız hızlandığını temizlemenin de çok bir anlamı yok demek. Bu koşullarda Windows kullanmak daha mantıklı olabilir.

2 Likes

Hocam öncelikle yardımlarınız için çok teşekkür ediyorum. Fan sorunsuz çalışıyor, yani gayet iyi duyuyorum. Uçak gibi sağ olsun. Disk bilgisini vermeniz iyi oldu… Sorun diskten kaynaklı olabilir diye düşünüyorum bu noktada. Zira distroların live versiyonunda sorun yok, diske kurulum yapınca sorun var. Üstelik disk epey eski ve çok da sağlıklı değil. Linux’un disklere karşı Windows’a kıyasla daha hassas olması da bu sorunların neden Windows’ta değil de Linux’ta yaşandığının kanıtı olabilir.

Bu bağlamda haklısınız, tüm bu koşullar göz önüne alındığında Windows kullanmak daha mantıklı gibi duruyor, her ne kadar istemesem de…

Sanırım yeni bir makine ya da disk alana kadar Linux kullanamayacağım gibi duruyor. Her dağıtımı, her masaüstü ortamını denedim zira. Hepsinde aynı problemler… Umarım yakın zamanda gönül rahatlığıyla Linux kullanabilirim diyelim o hâlde :slight_smile: Tekrar teşekkür ediyorum. Esen kalın, iyi forumlar

2 Likes

Fanın çalışması harika, ben ısıya bakarak çalışmadığını düşünüyordum. Malum göremediğimiz için ancak “sesi geliyor mu” gibi daha çok soyut çıktılara bakarak yorum yapabiliyorum. Kendim ve arkadaşımdan elde ettiğim deneyime göre ne HDD ne SSD düzgün çalışmıyorsa sistemde garip takılmalar, donmalar oluyordu. Disk performansı bayağı etkiliyor Linux’u. Windows’da bu sorunlar yaşanmıyordu aynı disklerle. USB’de tabii ki RAM’e kopyalandığı için sistem rahat çalışıyor. 250 GB’lik bir SSD(en fazla 500 liraya mal olur) ve düzgün bakım ile bilgisayarınızı çok daha uzun süre kullanılabilecek hale getirebilirsiniz. Bu donanım eski olsa da şu anda sahip olmak için ikinci el olsa bile en azından 4000 lira gözden çıkarmanız lazım ki ekran kartı çok kötü değil. Linux kurmak isterseniz tekrar yardımcı oluruz. Burada bayağı arkadaş var yardımcı olabilecek. Ancak şu anki durumda Windows daha iyi bir seçenek olarak gözüküyor.