Linux 'deposu 'i386' mimarisini desteklemediği için yapılandırılmış' hatası

Linux’da yeniyim ve repoların tam olarak nasıl çalıştığını anlayamadım ama update yapınca böyle hatalar alıyorum.

sefflex@Sefflex:~$ sudo apt update
Aynı:  1 http://tr.archive.ubuntu.com/ubuntu jammy InRelease
Aynı:  2 http://tr.archive.ubuntu.com/ubuntu jammy-updates InRelease           
Aynı:  3 http://tr.archive.ubuntu.com/ubuntu jammy-backports InRelease         
Aynı:  4 https://repo.steampowered.com/steam stable InRelease                  
Aynı:  5 http://security.ubuntu.com/ubuntu jammy-security InRelease            
İndir: 6 https://swupdate.openvpn.net/community/openvpn3/repos focal InRelease [6.840 B]
Aynı:  7 https://brave-browser-apt-release.s3.brave.com stable InRelease       
Hata:  6 https://swupdate.openvpn.net/community/openvpn3/repos focal InRelease 
  Aşağıdaki imzalar doğrulanamadı, çünkü genel anahtar mevcut değil: NO_PUBKEY 551180AB92C319F8
Aynı:  8 https://ppa.launchpadcontent.net/flatpak/stable/ubuntu jammy InRelease
Aynı:  9 https://dl.winehq.org/wine-builds/ubuntu jammy InRelease         
Paket listeleri okunuyor... Bitti
W: GPG hatası: https://swupdate.openvpn.net/community/openvpn3/repos focal InRelease: Aşağıdaki imzalar doğrulanamadı, çünkü genel anahtar mevcut değil: NO_PUBKEY 551180AB92C319F8
E: 'https://swupdate.openvpn.net/community/openvpn3/repos focal InRelease' deposu imzalanmamış.
N: Böyle bir depodan güvenli bir şekilde güncelleme yapılamaz, bu nedenle depo devre dışı bırakılmıştır.
N: Depo oluşturma ve kullanıcı yapılandırması hakkında ayrıntılı bilgi için apt-secure(8) rehber sayfasında bulunabilir.
N: 'https://brave-browser-apt-release.s3.brave.com stable InRelease' deposu 'i386' mimarisini desteklemediği için yapılandırılmış 'main/binary-i386/Packages' dosyası alınmıyor

Acaba bu hatalar nedir ve çözümleri nelerdir ?

Kendin yazılım kurmak için Ubuntu’ya depo eklemeye çalışmışsın herhalde ama yanlış depoları eklemişsin ya da eksik bir şekilde eklemişsin.

Resimdeki gibi Brave ve openvpn depolarını silmeni tavsiye ederim.

Bu tarz yazılımları mağazadan zaten kurabiliyor olman lazım. Örneğin Ubuntunun mağazasında brave tarayıcısı mevut: Install brave on Linux | Snap Store

Snap Brave takılıyordu ve donmalar yaşıyordum bende snap kullanamk istemediğimden flatpak indirdim her uygulmayı


bunu kapattım ama brave’i bulamadım. Tekrar update çekince bunlar karşıma çıktı:

sefflex@Sefflex:~$ sudo apt update
Aynı:  1 http://tr.archive.ubuntu.com/ubuntu jammy InRelease
Aynı:  2 http://tr.archive.ubuntu.com/ubuntu jammy-updates InRelease           
Aynı:  3 http://tr.archive.ubuntu.com/ubuntu jammy-backports InRelease         
Aynı:  4 https://repo.steampowered.com/steam stable InRelease                  
Aynı:  5 https://brave-browser-apt-release.s3.brave.com stable InRelease       
Aynı:  6 http://security.ubuntu.com/ubuntu jammy-security InRelease            
Aynı:  7 https://ppa.launchpadcontent.net/flatpak/stable/ubuntu jammy InRelease
Aynı:  8 https://dl.winehq.org/wine-builds/ubuntu jammy InRelease         
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
3 paket yükseltilebilir. Bu paketleri görmek için 'apt list --upgradable' komutunu çalıştırın.
N: '/etc/apt/sources.list.d/' dizinindeki 'brave-browser-release.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
N: '/etc/apt/sources.list.d/' dizinindeki 'steam-stable.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
N: '/etc/apt/sources.list.d/' dizinindeki 'flatpak-ubuntu-stable-jammy.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
N: '/etc/apt/sources.list.d/' dizinindeki 'openvpn3.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
N: '/etc/apt/sources.list.d/' dizinindeki 'steam-beta.list.save' dosyası geçersiz bir dosya uzantısı olduğu için yok sayılıyor
N: 'https://brave-browser-apt-release.s3.brave.com stable InRelease' deposu 'i386' mimarisini desteklemediği için yapılandırılmış 'main/binary-i386/Packages' dosyası alınmıyor

sürekli hatalar büyüyor gibi öğrenen kadar sanırım sürekli sıfırdan kurucam :smile:

Chat GPT bir çözüm buldu buraya yazayım aynı hatayla karşılaşanlar için:
GPT:

Bu çıktı, Ubuntu paket yöneticisi apt’in bir güncelleme işlemi sırasında aldığı bir bildirimi gösteriyor. Bildirimin ana bölümlerini açıklayalım:

  1. Depo Güncellemeleri: Sistem, çeşitli depolardan güncel bilgileri alır. Bu depolar, Ubuntu’nun resmi depoları ve ek depolar olabilir. Çıktıda, çeşitli depolardan güncellemelerin alındığı görülüyor.
  2. Hata Bildirimleri: Çıktıda, /etc/apt/sources.list.d/ dizinindeki bazı dosyaların geçersiz bir dosya uzantısı olduğu için yok sayıldığına dair bildirimler bulunuyor. Bu dosyalar, ek depoların tanımlandığı yerlerdir. Ancak, bu dosyaların “save” uzantılı olmaları beklenmiyor, bu nedenle bu dosyalar yok sayılıyor.
  3. Yükseltilebilir Paketler: Sistem, güncellenebilecek 3 paket olduğunu bildiriyor. Bu paketler, sistemde bulunan yazılımların yeni sürümleridir.
  4. Depo Uyarıları: Çıktının son kısmında, Brave Browser depolarının i386 mimarisini desteklemediği ve bu nedenle bu mimari için yapılandırılmış dosyanın alınamadığı bir uyarı bulunuyor. Bu, sisteminizde 32-bit mimariye sahip bir işlemci olmadığı anlamına gelir ve bu uyarı genellikle ihmal edilebilir.

Bu bilgiler ışığında, eğer sistemdeki paketleri güncellemek istiyorsanız, aşağıdaki komutu kullanabilirsiniz:

sudo apt upgrade

Ayrıca, depo dosyalarındaki geçersiz uzantılı dosyaları düzeltebilir veya silebilirsiniz. Örneğin:

sudo rm /etc/apt/sources.list.d/brave-browser-release.list.save
sudo rm /etc/apt/sources.list.d/steam-stable.list.save
sudo rm /etc/apt/sources.list.d/flatpak-ubuntu-stable-jammy.list.save
sudo rm /etc/apt/sources.list.d/openvpn3.list.save
sudo rm /etc/apt/sources.list.d/steam-beta.list.save

Daha sonra, depo bilgilerini güncellemek için şu komutu kullanabilirsiniz:

sudo apt update

bunların sonudunca tek hata kaldı:

N: 'https://brave-browser-apt-release.s3.brave.com stable InRelease' deposu 'i386' mimarisini desteklemediği için yapılandırılmış 'main/binary-i386/Packages' dosyası alınmıyor

bunun için ise :
Brave Browser Uyarısı: Brave Browser depolarının i386 mimarisini desteklemediği ve bu nedenle i386 mimarisine ait paket bilgilerinin alınamadığı bir uyarı bulunuyor. Ancak, bu uyarı genellikle ihmal edilebilir, çünkü çoğu modern sistemler 64-bit mimariye sahiptir.
söyledi Chat GPT umarım başkalarının sorunun çözümünde yardımcı olur.

1 Like