KDE Neon wine yüklerken "Broken wine-staging:amd64" hatası ve anahtarlar bozuldu

Bilgisayarın modeli Lenovo ideapad 1 Ryzen 7 5700u 82R4006FTR. Dağıtım KDE Neon Stable. Her şey wine-staging yüklemeye çalışırken başladı.

root@safak13:/home/durgunb# pacman -S wine-staging
==> sudo apt-get install wine-staging       
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) wine-staging:amd64 < none -> 5.12~eoan @un puN Ib >
Broken wine-staging:amd64 Bağımlılıklar on wine-staging-i386:amd64 < none @un H > (= 5.12~eoan)
Broken wine-staging:amd64 Bağımlılıklar on wine-staging-amd64:amd64 < none | 5.12~eoan @un uH > (= 5.12~eoan)
  Considering wine-staging-amd64:amd64 0 as a solution to wine-staging:amd64 9999
  Re-Instated libstb0:amd64
  Re-Instated libfaudio0:amd64
    Reinst Failed early because of libldap-2.4-2:amd64
Done
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 wine-staging : Bağımlılıklar: wine-staging-i386 (= 5.12~eoan) ama kurulabilir değil
                Bağımlılıklar: wine-staging-amd64 (= 5.12~eoan) ama kurulmayacak
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.

Sonra internetten bir kaç komut kopyaladım ama yanlışlıkla anahtarları bozdum. Yazılım kurarken hata veriyor.

Çıktı hali

W: file:/var/lib/preinstalled-pool/dists/jammy/Release.gpg: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION Secu section in apt-key(8) for details. E: 'http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu 16.04./ Release' deposunda Release dosyası yok. W: Böyle bir depodan güvenli bir şekilde güncelleme yapılamaz, bu nedenle depo devre dışı bırakılmıştır. W: Depo oluşturma ve kullanıcı yapılandırması hakkında ayrıntılı bilgi için apt-secure(8) rehber sayfasında bulunabilir. W: https://dl.winehq.org/wine-builds/ubuntu/dists/eoan/ InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

Bundan sonra bir şekilde anydesk kurdum bir kaç komutla. Fakat hala anahtar sorunu devam ediyor. Benim linux bilgim sıfır olduğu için anahtar listemi buraya veriyorum:

root@safak13:/home/durgunb# apt-key list
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
/etc/apt/trusted.gpg
--------------------
pub   rsa2048 2023-12-14 [SC]
      D637 DAC9 A59B EDCE B26C  CB47 74BB A5F0 44B8 F815
uid           [ unknown] Ubuntu Local Archive One-Time Signing Key <[email protected]>

pub   rsa3072 2018-12-10 [SC]
      D43F 6401 4536 9C51 D786  DDEA 76F1 A20F F987 672F
uid           [ unknown] WineHQ packages <[email protected]>

/etc/apt/trusted.gpg.d/org.kde.neon.net.launchpad.ppa.mozillateam.asc
---------------------------------------------------------------------
pub   rsa1024 2009-01-18 [SC]
      0AB2 1567 9C57 1D1C 8325  275B 9BDB 3D89 CE49 EC21
uid           [ unknown] Launchpad PPA for Mozilla Team

/etc/apt/trusted.gpg.d/ubuntu-defaults.key.gpg
----------------------------------------------
pub   rsa4096 2015-12-18 [SC]
      444D ABCF 3667 D028 3F89  4EDD E6D4 7362 5575 1E5D
uid           [ unknown] Neon CI

/etc/apt/trusted.gpg.d/ubuntu-keyring-2012-cdimage.gpg
------------------------------------------------------
pub   rsa4096 2012-05-11 [SC]
      8439 38DF 228D 22F7 B374  2BC0 D94A A3F0 EFE2 1092
uid           [ unknown] Ubuntu CD Image Automatic Signing Key (2012) <[email protected]>

/etc/apt/trusted.gpg.d/ubuntu-keyring-2016-dbgsym.gpg
-----------------------------------------------------
pub   rsa4096 2016-03-21 [SC]
      F2ED C64D C5AE E1F6 B9C6  21F0 C8CA B659 5FDF F622
uid           [ unknown] Ubuntu Debug Symbol Archive Automatic Signing Key (2016) <[email protected]>

/etc/apt/trusted.gpg.d/ubuntu-keyring-2018-archive.gpg
------------------------------------------------------
pub   rsa4096 2018-09-17 [SC]
      F6EC B376 2474 EDA9 D21B  7022 8719 20D1 991B C93C
uid           [ unknown] Ubuntu Archive Automatic Signing Key (2018) <[email protected]>

/etc/apt/trusted.gpg.d/ubuntustudio-ppa-ubuntu-backports.gpg
------------------------------------------------------------
pub   rsa4096 2019-02-07 [SC]
      1220 A5EC BA1F E99F 04CB  F741 F596 CF70 36BB AA6D
uid           [ unknown] Launchpad PPA for Ubuntu Studio PPA

W: The key(s) in the keyring /etc/apt/trusted.gpg.d/Release.gpg are ignored as the file has an unsupported filetype.

İki gündür uğraşıyorum ne wine staging kurabildim ne de anahtar sorununu halledebildim. Bilgim 0. Yardımcı olur musunuz lütfen?

http://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu 16.04

Merhaba, wine indirmek için eklediğiniz kaynaklardan birisi devre dışı bırakılmış. Yanlışıkla oradan dosya indirmesinler diye de RELEASE dosyası silinmiş. Verilen uyarılardan birisi bu. Dolayısıyla o repoyu kullanmamanız gerekiyor.

Anahtar konusuna gelince de son kullanma tarihi geçmiş veya yenisi yayımlanmış anahtarlar mevcut olabilir. Nerden nasıl eklediniz bu anahtarları bilmediğim için ona bir şey diyemeyeceğim. Eğer son kullanma tarihleri gözüküyor ve geçmiş ise onları silip yenilerini bulmanız gerekecek.

Kurulum için sizin kullandığınız işletim sistemi için şöyle bir rehber önerebilirim. Ubuntu’nun hangi sürümüne yakın/denk olarak anılıyor bilmiyorum. O nedenle linkteki 22.04 olan kısmı uygun bir sürümle değiştirip (muhtemeldir ki) uygun olan sürüm rehberine ulaşabilirsiniz.

2 Likes

Açıkçası anahtarlarla ne yapacağımı bilmiyorum. Rehber kesinlikle oluyor gibi görünüyor. Dediği şeyler bire bir çıktı ama anahtar sorunu devam ediyor. Nasıl çözmem lazım? Silmeyi veya yenisini indirmeyi bilmiyorum tam olarak öğrenmem lazım.

Güncelleme: Arkadaşlar şu an sorun için ilerleme kaydettik gibi görünüyor. Bir kaç gereksiz anahtarı sildik ve Release.gpg dosyasını masaüstüne atıp ilişiğini kestik. Update attığımda tek bir uyarı veriyor. Fakat wine-staging yüklerken hala büyük sorun yaşıyorum. Bir ton yanlış mimari yüklemişim:

==> sudo apt-get install wine-staging       
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) neon-adwaita:amd64 < 0.0+p22.04+trelease+git20220901.0903 @ii K Ib >
Broken neon-adwaita:amd64 Bozdukları on adwaita-icon-theme:amd64 < none -> 41.0-1ubuntu1 @un uN >
  Considering adwaita-icon-theme:amd64 23 as a solution to neon-adwaita:amd64 127
  Added adwaita-icon-theme:amd64 to the remove list
Broken neon-adwaita:amd64 Bozdukları on adwaita-icon-theme:i386 < none @un H >
  Considering adwaita-icon-theme:amd64 23 as a solution to neon-adwaita:amd64 127
  Added adwaita-icon-theme:amd64 to the remove list
Broken neon-adwaita:amd64 Bozdukları on humanity-icon-theme:amd64 < none -> 0.6.16 @un uN >
  Considering humanity-icon-theme:amd64 -1 as a solution to neon-adwaita:amd64 127
  Added humanity-icon-theme:amd64 to the remove list
Broken neon-adwaita:amd64 Bozdukları on ubuntu-mono:amd64 < none -> 20.10-0ubuntu2 @un uN >
  Considering ubuntu-mono:amd64 1 as a solution to neon-adwaita:amd64 127
  Added ubuntu-mono:amd64 to the remove list
  Fixing neon-adwaita:amd64 via keep of adwaita-icon-theme:amd64
  Fixing neon-adwaita:amd64 via keep of adwaita-icon-theme:amd64
  Fixing neon-adwaita:amd64 via keep of humanity-icon-theme:amd64
  Fixing neon-adwaita:amd64 via keep of ubuntu-mono:amd64
Investigating (0) libgtk-3-0:i386 < none -> 3.24.33-1ubuntu2 @un uN Ib >
Broken libgtk-3-0:i386 Bağımlılıklar on adwaita-icon-theme:i386 < none @un H >
  Considering adwaita-icon-theme:amd64 23 as a solution to libgtk-3-0:i386 0
  Holding Back libgtk-3-0:i386 rather than change adwaita-icon-theme:i386
Investigating (0) libsane1:i386 < none -> 1.1.1-5 @un puN Ib >
Broken libsane1:i386 Bağımlılıklar on libpoppler-glib8:i386 < none @un pH > (>= 0.18.0)
  Considering libpoppler-glib8:i386 0 as a solution to libsane1:i386 0
  Considering libpoppler-glib8:i386 0 as a solution to libsane1:i386 0
Investigating (1) libsane1:i386 < none -> 1.1.1-5 @un puN Ib >
Broken libsane1:i386 Bağımlılıklar on libpoppler-glib8:i386 < none @un pH > (>= 0.18.0)
  Considering libpoppler-glib8:i386 0 as a solution to libsane1:i386 0
  Considering libpoppler-glib8:i386 0 as a solution to libsane1:i386 0
Done
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 libsane1:i386 : Bağımlılıklar: libpoppler-glib8:i386 (>= 0.18.0) ama kurulabilir değil
                 Tavsiye ettikleri: sane-airscan:i386 ama kurulabilir değil
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.

Şimdi bağımlılıklar karmakarışık oldu. Aklına bir çözüm gelen var mı? Bir çok şey denedik ama elle silmek mi gerekir bilmiyorum.

Aynı sorunu ben de yaşadım ve ne yaparsam yapayım düzeltemedim en sonunda dağıtım değişerek çözdüm mecburen.

1 Like

Hocam ben şu an reboot attım. Komple tekrar kurdum. Wine-staging kde neon rehberi ile kuracağım. Fazladan kurduğum mimarileri silemiyoruz aşırı fazla var. Şu an sorun yok ama format atmama rağmen hala apt update ederken legacy key uyarısı alıyorum:

root@safak13:/home/durgunb# apt update
İndir: 1 file:/var/lib/preinstalled-pool jammy InRelease
Yoksay:1 file:/var/lib/preinstalled-pool jammy InRelease
İndir: 2 file:/var/lib/preinstalled-pool jammy Release [3.949 B]
İndir: 2 file:/var/lib/preinstalled-pool jammy Release [3.949 B]
Aynı:  3 http://archive.ubuntu.com/ubuntu jammy InRelease
İndir: 5 http://archive.neon.kde.org/user jammy InRelease [189 kB]                                           
Aynı:  6 http://archive.ubuntu.com/ubuntu jammy-updates InRelease                                            
Aynı:  7 http://security.ubuntu.com/ubuntu jammy-security InRelease                                          
Aynı:  8 https://ppa.launchpadcontent.net/mozillateam/ppa/ubuntu jammy InRelease    
1 sn.'de 189 kB alındı (237 kB/s)
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
Tüm paketler güncel.
W: file:/var/lib/preinstalled-pool/dists/jammy/Release.gpg: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.

Güncelleme: Bu da çözüldü. preinstalled-pool.list dosyasını başka bir dizine aldık düzeldi.

mv /etc/apt/sources.list.d/preinstalled-pool.list <hedef dizin>

komutunu kullandım. Hedef dizini için dosya yöneticisinden istediğiniz dosyayı açıp yukarıda yazan yoldan sağ tık ile kopyala diyebilirsiniz. Dosya konumu içinse dosyaya tıklayıp konumu kopyala deyin. Şimdi sırada wine-staging kurmak var :smiley:

Güncelleme: Rehberde libpoppler-glib paketini elle kurmamızı söylüyor ama paketin ubuntu sürümü bulunamıyor:

root@safak13:/home/durgunb# sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.2
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
libpoppler-glib8 paketi mevcut değil, ancak başka paket içerisinden işaret edilmiş.
Bu durum bu paketin kayıp, eskidiği için bırakılmış, ya da başka bir
yazılım kaynağında bulunduğu anlamına gelebilir.
Yine de aşağıdaki paketler onun yerine geçecek:
  libpoppler-glib8:i386

libpoppler-glib8:i386 paketi mevcut değil, ancak başka paket içerisinden işaret edilmiş.
Bu durum bu paketin kayıp, eskidiği için bırakılmış, ya da başka bir
yazılım kaynağında bulunduğu anlamına gelebilir.
Yine de aşağıdaki paketler onun yerine geçecek:
  libpoppler-glib8

E: 'libpoppler-glib8:i386' paketinin '22.02.0-2ubuntu0.2' sürümü bulunamadı
E: 'libpoppler-glib8' paketinin '22.02.0-2ubuntu0.2' sürümü bulunamadı
root@safak13:/home/durgunb# 

Hem 64bit hem de 32bit paketi kurmak istiyorsun. Öncelikle 32bit’i aktifleştirmek için

sudo dpkg --add-architecture i386

komutunu ardından da

sudo apt install libpoppler-glib8:{i386,amd64}

komutunu çalıştırman lazım. 22.02.0-2ubuntu paketi güncellendi. 0-3ubuntu var galiba şu an en son.

1 Like
Paket listeleri okunuyor... Bitti
Bağımlılık ağacı oluşturuluyor... Bitti
Durum bilgisi okunuyor... Bitti               
libpoppler-glib8 zaten en yeni sürümde (23.10.0-0xneon+22.04+jammy+release+build24).
libpoppler-glib8 elle kurulmuş olarak ayarlandı.
Starting pkgProblemResolver with broken count: 2
Starting 2 pkgProblemResolver with broken count: 2
Investigating (0) libpoppler-glib8:amd64 < 23.10.0-0xneon+22.04+jammy+release+build24 @ii pK Ib >
Broken libpoppler-glib8:amd64 Bozdukları on libpoppler-glib8:i386 < none -> 22.02.0-2ubuntu0.3 @un puN Ib > (!= 23.10.0-0xneon+22.04+jammy+release+build24)
  Considering libpoppler-glib8:i386 9998 as a solution to libpoppler-glib8:amd64 10002
  Conflicts//Breaks against version 22.02.0-2 for libpoppler-glib8 but that is not InstVer, ignoring
Investigating (0) libpoppler-glib8:i386 < none -> 22.02.0-2ubuntu0.3 @un puN Ib >
Broken libpoppler-glib8:i386 Bozdukları on libpoppler-glib8:amd64 < 23.10.0-0xneon+22.04+jammy+release+build24 @ii pK Ib > (!= 22.02.0-2ubuntu0.3)
  Considering libpoppler-glib8:amd64 10002 as a solution to libpoppler-glib8:i386 9998
  Conflicts//Breaks against version 23.09.0-0xneon+22.04+jammy+release+build22 for libpoppler-glib8 but that is not InstVer, ignoring
  Conflicts//Breaks against version 23.09.0-0xneon+22.04+jammy+release+build19 for libpoppler-glib8 but that is not InstVer, ignoring
  Conflicts//Breaks against version 23.09.0-0xneon+22.04+jammy+release+build18 for libpoppler-glib8 but that is not InstVer, ignoring
  Conflicts//Breaks against version 22.02.0-2 for libpoppler-glib8 but that is not InstVer, ignoring
Done
Bazı paketler kurulamadı. Bu durum, olanaksız bir durum istemiş
olduğunuzu ya da kararsız (unstable) dağıtımı kullandığınızı ve
bazı paketlerin henüz oluşturulamamış  ya da oluşturulmakta
olduğunu gösterir.
Aşağıdaki bilgiler durumu çözmenize yardımcı olabilir:

Aşağıdaki paketler karşılanmamış bağımlılıklara sahip:
 libpoppler-glib8 : Bozdukları: libpoppler-glib8:i386 (!= 23.10.0-0xneon+22.04+jammy+release+build24) ama 22.02.0-2ubuntu0.3 kurulacak
 libpoppler-glib8:i386 : Bozdukları: libpoppler-glib8 (!= 22.02.0-2ubuntu0.3) ama 23.10.0-0xneon+22.04+jammy+release+build24 kurulacak
E: Sorunlar giderilemedi, tutulan bozuk paketleriniz var.

hocam 32 bit yükledim en baştan. Tam dedim olacak. Olmadı. Muradıma eremiyorum :smiley:

Güncelleme: Arkadaşlar winehq-staging yükledim şu an. Çalıştıracağım ve deneyeceğim fakat şu ana gelmek için wise ile libpoppler glib paketinin ubuntu sürümlerini kontrol ettik. ubuntu0.2 ile biten yerine 0.3 ile biteni yükledim. Yani:

sudo apt install libpoppler-glib8:{i386,amd64}=22.02.0-2ubuntu0.3

Komutunu kullandım.
Uyarı: bu komuttan sonra apt update ve upgrade etmeyin. Anında ubuntu versiyonu silip neon versiyonu yüklüyor. Bu işlem zaten ubuntu0.3 versiyonuna düşürme. Sebep ise mimarilerden birinin libpoppler paketinin neon versiyonunu hiç bir şekilde görmemesi ve ilişik kuramaması. Neon versiyonu direk yok sayıyor. Çıktılardan birinde var bakıp görebilirsiniz. Baya sıkıntılı bir problem imiş.
Ardından:

sudo apt install --install-recommends winehq-staging

Dedim. Şimdi yüklendi. Fakat uygun libpoppler glib paketini bulmak için https://packages.ubuntu.com/ sitesine gidip libpoppler diye aratma yapmalısınız paketlerin içinde. Veya :
Ubuntu – Package Search Results -- libpoppler-glib

Wine’ı çalıştırıp konuyu güncelleyeceğim.

Merhaba, bir gelişme oldu mu en son Wine’ı çalıştırıp güncelleme yapacaktın ama gelmedi. Konu genel anlamıyla çözüldü aslında ama Wine’ı da çalıştırdığından emin olup öyle kapatırsak daha şahane olur diye düşünüyorum. :innocent: Sence?

Arkadaşlar sorun çözüldü wine ve yabridge sorunsuz çalışıyor. Tek sorun tekrardan KDE Neon kurmak zorunda kaldım ama çok fazla dosyam yoktu ondan sorun olmadı. Bu zamana kadar bekledim şimdi eminim. Dediğim gibi mimariyi paketin görmemesiyle alakalıymış. Aynı paketin neon versiyonu yerine ubuntu versiyonunu kurdum sorunsuz çalışıyor herkese teşekkürler.