Fedora Linux Heroic Games'de Alan Wake çalıştıramama sorunu

Epic games üzerinden sahip olduğum Heroic Games üzerinden çalıştıramıyorum Alan Wake’i çalıştıramıyorum. Steam’e ekleyip çalıştırmayı denedim ama olmadı. Fedora kullanıyorum

Bende oyun olmadığı için tam olarak işe yarar mı emin değilim ama bulduğum bir çözümü paylaşacağım. (Tabi farz ediyorum ki Alan Wake 2 oynamaya çalışıyorsun, eğer ilk oyunla ilgili problem yaşıyorsan ProtonDB - Alan Wake adresinden hangi ayarları yapman gerektiğini bulabilirsin, zaten oyun gold seviyede çalışıyormuş.)

Heroic Games Launcher’da oyunun resminin altındaki ayarlar kısmına tıklayıp Winetricks’e basıp "Open Winetricks GUI"ye (veya Türkçe yazıyorsa Winetricks GUI’yi aç gibi bir şey vardır) basıyorsun. Çıkan pencerede "Select the Default Wineprefix"i ardından “Install a Windows DLL or Component” kısmını seç. Çıkan pencerede d3dcompiler_43 ve d3dcompiler_47 yi işaretleyip en aşağılarda vcrun yazan paketleri 2015’ten 2022’ye kadar seçip hepsini yükle. Eğer VKD3D’yi aktif etmediysen yine oyunun resminin altındaki ayarlar kısmından aktif et.

EOS Overlay’i yüklemediysen Heroic ayarlarından kur.

Son olarak, export VKD3D_DISABLE_EXTENSIONS=VK_EXT_mesh_shader VKD3D_FEATURE_LEVEL=12_0 VKD3D_SHADER_MODEL=6_5 %command% bu kodu sanırım başlatma seçeneklerine (Launch Options) yapıştıracaksın öyle bir şey yoksa Proton Terminal demişler dediğim gibi konuya hakim değilim ama bulabileceğini düşünüyorum.

Bunları yaptıktan sonra hala çalışmazsa tekrar yaz.

3 Likes

çalıştı çok teşekkür ederim.