Fedora GTX 1650 Ti Driver kurulumu ve diğer sorunlar hakkında

Arkadaşlar merhaba, şu sıralar tekrar işletim sistemi değiştirip linux’a geçmek istiyorum ama bu geçişten önce geçmişte onlarca kez yaşadığım problemlerin çözümünü alarak başlamak istiyorum problemlerim her ne kadar basit olarak görünse de sürekli farklı bir arıza çıkması sebebiyle tamamen çözüme ulaştıramadım bu nedenle siz deneyimli linux kullanıcılarının yardımına ihtiyacım var. Her neyse başlayalım ilk olarak başlıkta da gördüğünüz gibi bir ekran kartı driver sorunum mevcut laptop modelim monster abra a5 v15.8.3 ekran kartı modelim de gtx 1650 ti bu ekran kartının driver kurulumunda her seferinde arıza çıkıyor bazen işletim sisteminin grafik arayüzü tamamen gidiyor bazen hiç kuramıyorum bu nedenle Fedora üzerinde bu driver’ı sorunsuz biçimde yüklemem için detaylı bir video yazı vb bir şey önerirseniz ya da sizler bu adımları yazarsanız sevinirim. İkinci sorunum ise ses ile alakalı bilgisayarımda ekstra olarak THX ismi veriler bir ses driver’ı var bunu windowsta kolaylıkla yükleyerek hoparlör ses yüksekliği performansını bayağı yükseltebiliyorum ancak linuxta araştırmalarım sonucunda böyle bir driver’a rastlamadım taa ki endeveour os u deneyene kadar ilginç bir biçimde endeveour os kullanırken ses seviyesi gayet driver kurulmuş gibi yüksek ve kaliteli idi yani ikinci sorunum da ise endeveour os taki bu program yahut driver’ı fedorada kullanmam mümkün mü? Cevaplarınız için şimdiden teşekkür ederim.

Foruma hoş geldin! :slight_smile:

Fedora’da NVIDIA sürücüsünü yüklemek kolay: Howto/NVIDIA - RPM Fusion

Kısaca bu komutları gireceksin.

sudo dnf update -y # and reboot if you are not on the latest kernel
sudo dnf install akmod-nvidia # rhel/centos users can use kmod-nvidia instead
sudo dnf install xorg-x11-drv-nvidia-cuda #optional for cuda/nvdec/nvenc support

Ama bu paketleri girebilmek için RPM Fusion deposunun aktif olması lazım.

sudo dnf install \
  https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm

sudo dnf install \
  https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

Bu iki komut aktif ediyor. Normalde kurulum esnasında sana soruyor olması lazım zaten eğer ki atladıysan bu şekilde aktif edebiliyorsun.

Ek olarak kurulum esnasında yine RPM Fusion’ı aktif ettiysen NVIDIA sürücülerini kuruyor olması lazım ama emin değilim. @Edip @mt190502 @Valentinus @quitaxd Fedora kullanıcıları daha iyi bilecektir. :smile:

Endavour OS’te bunun için özel bir program yok diye biliyorum. Orada normal çalıştıysa Fedora’da da normal çalışması lazım. Yine Fedora’yı da kurmadan önce canlı masaüstü ortamından deneyebilrisin.

Linux’ta ses seviyesini %100’ün üzerine çıkarmak için ek bir sürücü yüklemenize gerek yok. Ayarlardan maksimum ses seviyesinin üstüne çıkar seçeneğine izin veriyorsunuz ve %150 %200 gibi seviyelere sesi çıkartabiliyorsunuz.

3 Likes

Ben en son kurdugumda RPM Fusion’u kendim actim. (Fedora Everything kurmustum. Eger acik degilse zaten rahatca acilir.) Driver paketlerini kendim kurdum sonra sistemi yeniden baslattim oldu. (sudo dnf update -y && sudo dnf in akmod-nvidia xorg-x11-drv-nvidia-cuda -y kurulum komutu) Eger yanlisim varsa biri beni duzeltsin lutfen.

yardımınız için teşekkürler ekran kartı driverlarını başarı ile kurdum ve ses ayarlaması için gerekli komutu da buldum lakin şimdi şöyle bir sıkıntı var herhangi bir video müzik vs başlattığımda başlattıktan bir iki saniye sonra ses geliyor içeriğin geri kalan kısmında bir sorun ya da gecikme yok ama bu her video başlattığımda oluyor bu nedenle videoları sürekli geri sarmak zorunda kalıyorum bu sorunu nasıl çözebilirim?

Bu uzun süre hoparlörü kullanmadığında module-suspend-on-idle’ın tetiklenmesiyle oluyor. Bunu kapatmanın yolu var. Kaynak olarak şu rehberi göstereceğim: Disable Pipewire Suspend on Idle to avoid audio pops, delays, and white noise

  1. sudo mkdir -p /etc/wireplumber/main.lua.d/
  2. sudo cp -a /usr/share/wireplumber/main.lua.d/50-alsa-config.lua /etc/wireplumber/main.lua.d/50-alsa-config.lua
  3. sudo nano /etc/wireplumber/main.lua.d/50-alsa-config.lua
  4. Dosyanın en altında --["session.suspend-timeout-seconds"] = 0, göreceksin. En baştaki 2 tireyi silip = 0 yapman lazım. Varsayılan olarak 5 yazacak.
  5. systemctl --user restart wireplumber

Bu şekilde sorunun çözülmüş olması lazım. Normalde bu güç tüketiminin azaltılması için yapılıyor ama dilersen bu şekilde düzeltebilirsin.

1 Like

Evet bu sorunum da çözüldü yardımlarınız için çok teşekkürler.

1 Like