Arch parlaklığı ayarlayamıyorum

HP Victus laptopa archinstall ile arch ve wayland kurulumu yaptım ilk farkettiğim sorun sys/class/backlight/amdgpu_0/brightness değerini azalttığımda parlaklığın artması, arttırdığımdada azalmasıydı. Bu sorunu /etc/default/grub dosyasına “acpi_osi=Linux” ve “acpi_backlight=vendor” parametrelerini ekleyerek çözdüm(çözdükten sonra şunu farkettim sys/class/backlight içindeki amdgpu_0 dosyası silinmiş). Daha sonra waybar configimi düzenlerken farkettim ki parlaklığımı karttırıp azaltamıyorum farklı modüller ve parlaklığı ayarlamak için arch wikideki ilgili programları denedim fakat hiçbiri çalışmıyor. Temelde istediğim şey waybar üzerinden mause tekerleği ile parlaklığı ayarlayabilmek modüle tıkladığımda ise nightshift açıp kapatabilmek.
Linuxta driverlar hakkında gram bilgim yok hangi driverın yüklü olduğuna bile bakıyorum, archinstall da propiertry sürücüleri seçmiştim. Sistemimde r5 5600h dahili ve GTX1650 harici gpu var.

Grub’a default parametre ekleyerek /sys/class/backlight üzerinden parlaklık ayarlama sorununu çözmüşsün sanırım. Waybar’da shell script çağırma özelliği vardır, mouse scroll’un script çağıracak şekilde bir yapı kurup scriptler ile de /sys/class/backlight’a yazarak parlaklığı ayarlayamaz mısın?

Dediğin şey mantıklı fakat belirttiğim gibi grub’a parametre ekledikten sonra sys/class/backlight içindeki dosya silindi ve tamamen boş oradan hiçbir şekilde ayarlama yapamıyorum. "parlaklık sorununu çözdüm"den kastım grub’dan sonra artık parlaklığım tamamen full oluyor. Farklı terminal programları ile denedim fakat parlaklığımı değiştiren bir programda bulamadım şu an herhangibir şekilde parlaklığımı ayarlayamıyorum.

şu an /sys/class/backlight altında ne var, tamamen boş mu?

Evet tamamen boş. “ls -a” komutuyla gizli dosyalarıda kontrol ettim.

/etc/default/grub dosyasının içeriğini paylaşabilir misin hocam

Hocam konuyu açtığımdan beri bu sorunla uğraşıyorum bakmadığım forum okumadığım rehber kalmadı en son chatGPT’ye sorayım dedim bana bazı kodlar verdi onları grub dosyama eklememi söyledi fakat ekledikten sonra sorunum en başa geri döndü kodları dosyadan çıkarsam bile hiçbir değişiklik olmadı. Şu an son durum şöyle /sys/class/backlight altında amdgpu_bl1 dosyam var fakat bu dosyadaki brightness değerini arttırdığımda parlaklığım kısılıyor azalttığımda açılıyor ve değeri 0 yapsam bile tam parlaklığıma ulaşamıyorum /etc/default/grub dosyamın içeriği ise şöyle:

# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi_osi=Linux acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="rootfstype=ext4"

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y

# Probing for other operating systems is disabled for security reasons. Read
# documentation on GRUB_DISABLE_OS_PROBER, if still want to enable this
# functionality install os-prober and uncomment to detect and include other
# operating systems.
#GRUB_DISABLE_OS_PROBER=false

Chatgpt den bu tür önenli şeyleri yapmak biraz sakat. Eğitildiği verileri yoğurarak cevapladığı için yanlış flagler vb ekleyebilir. Değişik sıkıntılar verebilir.

Normalde bende tercih etmezdim ama son çare olarak deneyeyim dedim zaten kaydetmeden öncede anladığım kadarıyla kontrol ettim ama böyle bir sıkıntıya sebep olabileceği aklımdan bile geçmedi.

ben script kullanıyorum f9 ve f10 tuşlarına ayarlı. soldoestech’in dosyası vardı normalde configlerini beğenmesem de bootstrapi iyi

dosya bu şekilde bakabilirsin #!/usr/bin/env bash

iDIR=“$HOME/.config/HyprV/mako/icons”

Get brightness

get_backlight() {
LIGHT=$(printf “%.0f\n” $(brightnessctl i))
echo “${LIGHT}%”
}

Get icons

get_icon() {
backlight=“$(brightnessctl g)”
current=“${backlight%%%}”
if [[ (“$current” -ge “0”) && (“$current” -le “52”) ]]; then
icon=“$iDIR/brightness-20.png”
elif [[ (“$current” -ge “52”) && (“$current” -le “103”) ]]; then
icon=“$iDIR/brightness-40.png”
elif [[ (“$current” -ge “103”) && (“$current” -le “155”) ]]; then
icon=“$iDIR/brightness-60.png”
elif [[ (“$current” -ge “155”) && (“$current” -le “207”) ]]; then
icon=“$iDIR/brightness-80.png”
elif [[ (“$current” -ge “180”) && (“$current” -le “255”) ]]; then
icon=“$iDIR/brightness-100.png”
fi
}

Notify

notify_user() {
notify-send -h string:x-canonical-private-synchronous:sys-notify -u low -i “$icon” “Brightness : $(brightnessctl g)”
}

Increase brightness

inc_backlight() {
brightnessctl set 10%+ && get_icon && notify_user
}

Decrease brightness

dec_backlight() {
brightnessctl set 10%- && get_icon && notify_user
}

Execute accordingly

if [[ “$1” == “–get” ]]; then
brightnessctl g
elif [[ “$1” == “–inc” ]]; then
inc_backlight
elif [[ “$1” == “–dec” ]]; then
dec_backlight
else
get_backlight
fi

Dostum bu config parlaklığı brightnessctl aracı ile alıp ayarlıyor, maalesef bendeki sorun hiçbir aracın çalışmıyor olması yinede teşekkürler.

Hocam arch wikide yazdığına göre acpi_backlight parametresi kernel 6.1’de değişmiş. Ve henüz kimse hangi seçeneğin ne işe yaradığını bilmiyor gibi tek tek deneyin demiş. Biraz uğraştıracak ancak acpi_backlight parametresini tek tek video, vendor, native ve nvidia_wmi_ec değerleriyle deneyebilir misin? Her değer için /sys/class/backlight’ın altında hangi klasörlerin olduğunu not edip benimle paylaşır mısın?

Hocam kusura bakmayın sınava hazırlandığımdan dolayı sadece akşamları pcye oturabiliyorum verdiğiniz değerleri denedim ve şu sonuçları elde ettim:

nvidia_wmi_ec: parlaklığım full fakat backlight dosyası boş

vendor: parlaklığım full fakat backlight dosyası boş

native: parlaklığım kısık backlight dosyasının içinde amdgpu_bl1 dosyası var fakat ayarlanmıyor(soruda belirttiğim şekilde)

video: Parlaklığım full şekilde geliyor acpi_video0 dosyası var brightness dosyasının default değeri 49 fakat değiştirdiğimde parlaklık değişmiyor

native olduğu durumda /sys/class/backlight/amdgpu_bl1’in altında neler var? varsa actual_brightness, brightness ve max_brightness dosyalarındaki değerleri paylaşabilir misin?

Ekran driverlerinizi kurmayı denedinizmi?

/sys/class/backlight/amdgpu_bl1 altında; actual_brightness, bl_power, brightness, device, max_brightness, power, scale, subsystem, type, uevent dosyaları var.
actual_brightness : 0
brightness : 126
max_brightness : 255

Ekran kartı driverlarından bahsediyorsanız archinstall ile kurulum yaptım ve kurulum sırasında property driverları seçtim, kurulum sırasında hata almadım.

Aslında her şey gayet norma duruyor ya. Şimdi bu durumda

sudo echo 200 > /sys/class/backlight/amdgpu_bl1/brightness

komutunu çalıştırınca parlaklık azalıyor öyle mi? Peki brightness’ı 0 yapınca parlaklık maksimum, 255 yapınca da parlaklık minimum seviyeye mi geliyor?

BACKLIGHT_DEVICE="$(basename /sys/class/backlight/*)"

cat /sys/class/backlight/$BACKLIGHT_DEVICE/max_brightness      # max verilebilecek parlaklik seviyesi
cat /sys/class/backlight/$BACKLIGHT_DEVICE/brightness          # o anki parlaklik seviyesi

Aynen öyle bu komutu verdiğimde parlaklığım azalıyor, 255 değerini verdiğimde ise minimum parlaklığa ulaşıyorum fakat asıl sorun şu ki 0 değerini verdiğimde maximum parlaklığıma ulaşamıyorum.